Issues with embedded content requiring a log in

Tags Mediasite

Issue 

Content embedded into Canvas requests re-authentication that may fail

Cause

Students may have trouble viewing presentations embedded improperly into Canvas.  Make certain you are using the built in LTI tool to embed your presentations and are not copying the embed code or links from Mediasite.

A proper link will include reference to the Canvas external tool, while a problematic link would only include the Mediasite URL.  The reference to the tool is required to authenticate successfully.

no Bad:  https://fau.mediasite.com/Mediasite/Lti/Home/Launch?mediasiteId=59dc0965400f4eff809cc222c0067c911d

yes Good:  <iframe style="width: 1024px; height: 512px;" src="https://canvas.fau.edu/courses/104071/external_tools/retrieve?0=0&amp;url=https://fau.mediasite.com/Mediasite/Lti/Home/Coverplay?mediasiteId=880b540e0b7f4634b4290de138aebc281d&amp;borderless=1"></iframe>

Resolution

To fix the issue at the source, instructors should re-embed the content using the Mediasite/Canvas integration in the text editor

Print Article

Related Articles (1)

Linked and Embedded videos must use the "Add Medisite Video" tool in the Canvas Rich Editor.